VRayScatter For Maya Manual

VRayScatter For Maya is a plug-in for Maya which works with V-Ray rendering system. It is possible to create complicated scenes with a huge amount of objects easy and quickly with the aid of this plugin.

Usually scenes in Maya with a great amount of even identical objects take a lot of space on HDD, consumes a lot of time for loading, and it is very hard to work with. VRayScatter For Maya is created to solve these problems.

The scene containing 500 000 identical objects created with Maya 2008 occupies 1400Mb of HDD space. Now, if it is created with VRayScatter For Maya and still containing the same 500 000 objects the scene can take just 250Kb.

The most exciting feature of VRayScatter For Maya is a quick generation of an array of objects right before rendering. Those very 500 000 objects are created in only 2 seconds before rendering.

Another outstanding VRayScatter For Maya ability is uploading and downloading from VRayProxy memory if needed (as and when necessary). This allows the application of polygon models without missing productivity and capacity of RAM. Animated objects support and animated VRayProxy support allows creating huge amounts of animated objects. Now with VRayScatter For Maya it is possible to create the whole forest of wind-shaken woods. The support of 64-bit systems and multi-core processing allows VRayScatter For Maya to create and render, for example, forest or even a city in a blink of an eye.

System Requirements

Operating system:

  • Windows
  • Mac OS X (for Mac users: please contact us before purchasing)
  • Linux

Maya versions:

  • Windows: 2009, 2010, 2011, 2012, 2013, 2014, 2015, 2016, 2016.5, 2017
  • Mac OS X: 2010, 2011, 2012, 2013, 2014, 2015, 2016, 2016.5
  • Linux: 2009, 2010, 2011, 2012, 2013, 2014, 2015, 2016, 2016.5, 2017

V-Ray versions:

  • Windows / Linux / Mac OS X: 2.0, 2.2, 2.3, 2.4, 3.1 ( 3.00.01 is not compatible, but some nightlies like 3.05.04 are compatible), 3.3 , 3.4+ (best performs with latest nightlies)

Architecture:

  • Windows: 32/64 bit
  • Mac OS X: 32/64 bit
  • Linux: 64 bit

NOTE:

  • User must be able to obtain root permissions (using sudo, for example) to install VRayScatter For Maya.

Rendernodes:

  • VRayScatter without activation supports only batch render from command prompt (render.exe or mayabatch.exe) and rendering with vray standalone.
  • For rendering from Maya GUI (render→batch render) activation is required

Upgrade from 2.x.x to 4.x

Version 3.x.x and 4.x now uses only one V-Ray plugin file so you have to remove old conflicting plugins:

  • Windows: uninstall previous version of VRayScatter For Maya using the uninstaller.
  • Linux: remove libvray_GeomRamProxy.so and libvray_TexVRayScatter.so from /usr/autodesk/maya<MAYA_VERSION>-x64/vray/vrayplugins/
  • OS X: remove libvray_GeomRamProxy.so and libvray_TexVRayScatter.so from /Applications/Autodesk/maya<MAYA_VERSION>/Maya.app/Contents/vray/vrayplugins/
  • DR nodes: manually remove libvray_GeomRamProxy.* and libvray_TexVRayScatter.*

Windows

Installation

Please, make sure that you've downloaded the latest version of the plug-in from our forum

To install the program you need to run the VRayScatterForMaya-<version>.exe with the administrator rights.

Don’t forget to quit Maya before you start the installation (please check Task Manager too for any running instances of Maya).

 VRayScatter for Maya installer

Read the license agreement carefully. If you accept the license the click “I Agree” otherwise press “Cancel”:

 VRayScatter for Maya installer

Choose Maya version, V-Ray version and the architecture:

 VRayScatter for Maya installer

Check installation paths

 VRayScatter for Maya installer

Start Maya and enable Load and/or Auto load in Window → Settings/Preferences → Plug-in Manager for the VRayScatter plug-in.

 VRayScatter for Maya autoload

Installation on Windows DR nodes

Copy vray_VRayScatter.dll from MAYA_ROOT/vray/vrayplugins to VRAY_STANDALONE/vrayplugins (or MAYA_ROOT/vray/vrayplugins) on render nodes.

(or whichever folder is used for loading vray plugins from, the folder is usually called /vrayplugins and locates within your V-Ray standalone installation)

For example, from:

C:\Program Files\Autodesk\Maya2012\vray\vrayplugins

to:

C:\Program Files\Chaos Group\V-Ray\Standalone\vrayplugins

Uninstall

To uninstall VRayScatter use the uninstaller: Start menu > R&D Group > VRayScatter For Maya > Uninstall

Activation

Linux

General

Please, make sure that you've downloaded the latest version of the plug-in from our forum

Here is an example file structure of the VRayScatter For Maya for Linux / Mac OS X archive:

  • plugins – plugins:
    • workstation – artist workstation
    • batch – for batch render nodes
  • shaders – description files for V-Ray shaders
  • ui – UI files for Maya
  • tools – registration tools

Installation On Linux

Please, make sure that you've downloaded the latest version of the plug-in from our forum

Unpack the archive, open your preferred terminal application, obtain root permission

Installer has a graphical interface on all supported platforms:

$ sudo -i
# VRayScatterForMaya-x.xxx.run

or you can also run text installation mode

$ sudo -i
# VRayScatterForMaya-x.xxx.run --mode text

Select you Maya/V-Ray versions and copy the plugins:

# cp plugins/workstation/maya2012_vray22_x64/VRayScatter.so /usr/autodesk/maya2012-x64/bin/plug-ins/
# cp plugins/workstation/maya2012_vray22_x64/libvray_VRayScatter.so /usr/autodesk/maya2012-x64/vray/vrayplugins/

Install the Maya UI files:

# cp ui/AEVRayScatterTemplate.mel /usr/autodesk/maya2012-x64/scripts/AETemplates/
# cp ui/AEVRayScatterTextureTemplate.mel /usr/autodesk/maya2012-x64/scripts/AETemplates/
# cp ui/rdgroupVRayScatter.mel /usr/autodesk/maya2012-x64/scripts/
# cp ui/rdgroupMenu.mel /usr/autodesk/maya2012-x64/scripts/
# cp ui/rdgroupProc.mel /usr/autodesk/maya2012-x64/scripts/

Install the V-Ray texture description file:

# cp shaders/VRayScatterTexture.txt /usr/autodesk/maya2012-x64/vray/shaders/

NOTE:

  • Change the installation paths depending on your setup
  • # - means that command should be executed with root permissions

Installation On Linux Batch Render Nodes

Change directory to where you have unpacked the archive:

$ sudo -i
# cd ~/where/you/have/unpacked/the/archive

Select you Maya/V-Ray versions and copy the plugins:

# cp plugins/batch/maya2012_vray22_x64/VRayScatter.so /usr/autodesk/maya2012-x64/bin/plug-ins/
# cp plugins/batch/maya2012_vray22_x64/libvray_VRayScatter.so /usr/autodesk/maya2012-x64/vray/vrayplugins/

Install the V-Ray texture description file:

# cp shaders/VRayScatterTexture.txt /usr/autodesk/maya2012-x64/vray/shaders/

Installation On Linux DR Nodes

For V-Ray “Distributed Render” node installation you only need to copy V-Ray plugins:

$ sudo -i
# cd ~/where/you/have/unpacked/the/archive/workstation/maya2012_vray22_x64/
# cp libvray_VRayScatter.so /usr/autodesk/maya2012-x64/vray/vrayplugin/

Uninstall

To uninstall VRayScatter For Maya you have to manually remove all the installed files.

Activation on Linux

Mac OS X

Installation on Mac OS X

Please, make sure that you've downloaded the latest version of the plug-in from our forum

Unpack the archive, open your preferred terminal application, obtain root permission and start coping files:

$ sudo -i
# cd ~/where/you/have/unpacked/the/archive

Select you Maya/V-Ray versions and copy the plugins. Here is an example for the default paths of Maya 2012 and V-Ray 2.2:

# cp plugins/workstation/maya2012_vray22_x64/VRayScatter.dylib /Applications/Autodesk/maya2012/Maya.app/Contents/MacOS/plug-ins
# cp plugins/workstation/maya2012_vray22_x64/libvray_VRayScatter.so /Applications/Autodesk/maya2012/Maya.app/Contents/vray/vrayplugins/

Install the Maya UI files:

# cp ui/AEVRayScatterTemplate.mel /Applications/Autodesk/maya2012/Maya.app/Contents/scripts/AETemplates
# cp ui/AEVRayScatterTextureTemplate.mel /Applications/Autodesk/maya2012/Maya.app/Contents/scripts/AETemplates
# cp ui/rdgroupVRayScatter.mel /Applications/Autodesk/maya2012/Maya.app/Contents/scripts/
# cp ui/rdgroupMenu.mel /Applications/Autodesk/maya2012/Maya.app/Contents/scripts/
# cp ui/rdgroupProc.mel /Applications/Autodesk/maya2012/Maya.app/Contents/scripts/

Install the V-Ray texture description file:

# cp shaders/VRayScatterTexture.txt /Applications/Autodesk/maya2012/Maya.app/Contents/vray/shaders

NOTE:

  • Change the installation paths depending on your setup
  • # - means that command should be executed with root permissions

Installation On Mac OS X Batch Render Nodes

Change directory to where you have unpacked the archive:

$ sudo -i
# cd ~/where/you/have/unpacked/the/archive

Select you Maya/V-Ray versions and copy the plugins:

# cp plugins/batch/maya2012_vray22_x64/VRayScatter.so /Applications/Autodesk/maya2012/Maya.app/Contents/MacOS/plug-ins
# cp plugins/batch/maya2012_vray22_x64/libvray_VRayScatter.so /Applications/Autodesk/maya2012/Maya.app/Contents/vray/vrayplugins

Install the V-Ray texture description file:

# cp shaders/VRayScatterTexture.txt /Applications/Autodesk/maya2012/Maya.app/Contents/vray/shaders

Installation On Mac OS DR Nodes

For V-Ray “Distributed Render” node installation you only need to copy V-Ray plugins:

$ sudo -i
# cd ~/where/you/have/unpacked/the/archive/workstation/maya2012_vray22_x64/
# cp libvray_VRayScatter.so /Applications/Autodesk/maya2012/Maya.app/Contents/vray/vrayplugins/

Uninstall

To uninstall VRayScatter For Maya you have to manually remove all the installed files.

Activation on Mac OS X

NOTE

  • You don't need a license for Batch and DR nodes.

Please make sure you always use the registration utility which is supplied with the particular version of VRayScatter For Maya.

Open your preferred terminal application and start the registration utility:

$ /Applications/iCubeRDGroup/bin/VRayScatterForMayaRegistration

This will generate an VRayScatterForMaya_<UserName>_<Date>.id file on your Desktop.

Send this file to mail@rendering.ru (or your reseller). Please, attach copy of you receipt or order number to avoid any delays in communication.

In the nearest time (usually within 24 hours) you will get an email from us (or your reseller) with *.lic license file attached. Save this file on your hard disk.

Start again the registration utility with the path to the license file argument like:

$ /Applications/iCubeRDGroup/bin/VRayScatterForMayaRegistration /path/to/license/file.lic

or manually copy this file to ~/.config/RDGroup/VRayScatterForMaya.lic like this:

$ mkdir -p ~/.config/RDGroup/
$ cp /path/to/license/file.lic ~/.config/RDGroup/VRayScatterForMaya.lic

In case of license malfunction and errors (which can be caused by disk formatting, reinstallation of the operating system or components replacement) you are free to address the developer at any time. Please make sure you download latest version from our forum and generate new *.id file. Send it to mail@rendering.ru to get your updated *.lic file.

However, we reserve the right not to issue a new license in case of total replacement of a PC if the registration request is submitted more often than once in half a year.

ATTENTION! Please always try to email from the same email address you used when you purchased the plug-in. If we can’t find your e-mail address from which you sent the ID file in our database and there is no explanation and receipt or order number in you email, your request may not be processed!

Please always attach you receipt or order number to avoid any delays in communication.

Usage

VRayScatter Creation

  1. Select mesh or curve object you want to distribute objects at.
  2. In menu choose: Create → R&D Group → VRayScatter.
  3. VRayScatter bounding box and logo will appear. Use it to select VRayScatter.

User Interface

 VRayScatter for Maya interface

  1. Select objects to distribute (Mesh or VRayProxy) then select VRayScatter and press Add in «Scatter Objects» rollout. This will connect objects to the “scatterObject” attribute.
  2. If you have added multiple objects tweak the Probability parameter to make all objects visible or use menu Tools → “Auto Probability”.

Parameters Description

Scatter Objects rollout

  • Scatter Objects – list of scattered objects.
  • Draw Color – object's drawing color in viewport.
  • Probability – probability of the object's appearance.
  • Radius – radius of the collision sphere for the collision solving. Default value is 100% - that corresponds to the object size.
  • Height – addition offset of the collision sphere.
  • Penetration – sets the blur of the collisions border areas.
  • Mask color variance – threshold for colorful mask.
  • Hide From Render – hide original object from render.

Distribution

  • Seed – initial random seed.
  • Amount – render objects amount.
  • Preview – preview objects amount.
  • Instancing type:
    • Intance - this is the default type for huge object amounts
    • Node - use this type for smaller object amounts (< 100,000) and if you need to scatter displaced or smoothed geometry. This type also provides motion blur when using animated VRayProxy and compatible with VRay RT.
  • Use Mask – use distribution mask texture.
  • Colorful - use colorful mask; this will place objects by the texture using object “Draw Color”.
  • Texture – distribution mask texture. This could be any Maya texture.
  • Solve Collisions – solve scatter objects collisions.

Pattern

  • Type – pattern type
    • Random
      • Use Density – random position settings include only this one additional option. With it you can set the number of objects (Count) to be located at a single area unit (Per Square). The resulting number will also be fixed with ‘Max Count’ option. The area is defined by system units. It means that in the case when centimetres being used in system units one single object will fall within 1 square meter.
    • Pattern - Pattern distribution uses UV-mapping to work, thus object must have proper UV-coordinates.
      • Lock Offsets – when this option is enabled you will to control both U and V offsets simultaneously.
      • U Offset – U offset.
      • V Offset – V offset.

Rotation

  • Use – quick control to enable/disable rotation features.
  • Align To Normal – align object to surface normal.
  • Constant – constant rotation (for each axis).
  • Random – random rotation (for each axis).
  • Use Texture – Use rotation texture.
  • Texture – rotation texture. Red color represents rotation around X, Blue – Y, Green – Z. Color value 0.0 equals to rotation of 180 degrees to one direction, color value of 0.5 leaves the rotation state unchanged, color value of 1.0 makes the rotation of 180 degrees to another direction.
  • Use X, Y, Z – quick control to enable/disable rotation about each axis when using texture.
  • Texture contrast – quick control of texture contrast.

Scale

  • Use – quick control to enable/disable scale features.
  • Global From/To – global minimum/maximum scale. The actual scale will be a random value between From and To values.
  • Local From/To – per-axis minimum/maximum scale. The actual scale will be a random value between From and To values.
  • Use Texture – Use scale texture.
  • Texture – scale texture. Red color represents X scale, Blue – Y, Green – Z.
  • Max Scale – maximum scale that corresponds to the 1.0 color value.

Offset

  • Use – quick control to enable/disable offset features.
  • Along Normal – offset objects along surface normal.
  • From/To – minimum/maximum offsets. The actual offset will be a random value between From and To values.
  • Normal – additional normal offset.
  • Use Texture – Use offset texture.
  • Texture – offset texture. Red color represents X offset, Blue – Y, Green – Z.
  • Max Offset – maximum offset that corresponds to the 1.0 color value.

Distance to surface borders

  • Use – quick control to enable/disable surface border features.
  • Distance – maximum distance from object to surface border in which object parameters will be affected. Actual control parameter behavior could be defined using Density and Scale ramps.

Distance to curve borders

  • Use – quick control to enable/disable curve border features.
  • Distance – maximum distance from object to curve in which object parameters will be affected. Actual control parameter behavior could be defined using Density and Scale ramps.
  • Attach Curve – attaches selected curve.

Mask curve

  • Use – quick control to enable/disable mask curve features.
  • Inverse – inverse mask curve behavior.
  • Attach Curve – attaches selected curve.

Camera

  • Use – quick control to enable/disable camera features.
  • Use FOV – limits rendered objects to only that are seen from camera field of view. Could save some RAM.
  • Distance – distance from camera.
  • Affect Density – limits objects visibility to distance.
  • Attach Camera – attaches selected camera.

Render

  • Use Light Linker - this feature will transfer Light Linker setup from objects used in scatter to instanced objects.
  • Use Tint Texture - check VRayScatter Texture section for howto.
    • Replace Color - this will replace the color with Tint Texture color, otherwise it will be mixed.
    • Type - mix type.
    • Amount - mix amount.
    • Tint Texture - color variance control texture.
  • Use Render Stats - this feature allows to setup render stats options

VRayProxy Animation

This feature works only when scattering VRayProxy and allows to assign different frame offset.

  • Use – quick control to enable/disable VRayProxy animation features.
  • Offset From/To – From/To frame offset. Actual frame offset is a random value between From and To.
  • Use Offset Texture - use texture to drive frame offset; black = “Offset From” value, white = “Offset To” value.

Viewport

  • Draw style – objects draw style in the viewport.
  • Logo color - color for the locator logo and bounding box.
  • Logo size – locator logo size.

Bake

This feature allows to “bake” scattered objects to real Maya objects. Use this feature very carefully because it could add too much objects to your scene.

  • Bake Type
    • Instance - new objects will be linked with one geometry.
    • Cope - geometry data will also be duplicated.

VRayScatter Texture

VRayScatter texture is used for color randomization of scattered objects. To use this feature do the following:

Setup VRayScatter:

  1. Enable “Use Tint Texture” option in VRayScatter's “Render” rollout.
  2. Setup “Tint Texture”. You could use any Maya texture to control color variance (like Noise or File)

Setup scattered object (this example uses diffuse color variance):

  1. Make sure object uses “VRay Mtl”
  2. Add “VRay Scatter Texture” to diffuse slot. “VRay Scatter Texture” is located in “Utilities” section in Maya textures.
  3. Add “Base Texture” to “VRay Scatter Texture” if needed

Now render your scene and look at color variance.

Troubleshooting

License error

VRayScatter: Incorrect license!

if this is happens right after activation, please restart Maya

In case of license malfunction and errors (which can be caused by disk reformatting, re-installation of the operating system or components replacement) you are free to address the developer at any time by sending your request for a new *.LIC file to mail@rendering.ru.

However, in the case of total replacement of a computer by a new one new license is not provided more often than once in half a year.

Installation error

 VRayScatter for Maya installation error

Make sure Maya is not running, please double check in task manager too.

Make sure you are installing with the administrator rights (on Windows 7 right click “Run as administrator”) .

Make sure you choose right installation path

Does not appear in create menu

  • Please make sure all files were placed into right folders (please see “manual installation” below)
  • Start Maya and enable Load and/or Auto load in Window → Settings/Preferences → Plug-in Manager for the VRayScatter plug-in.

Manual installation

2009-2014 - are Maya versions
20, 22, 23, 24, nightly - are V-Ray versions (20 => 2.0, 24 => 2.4
etc, nightly means some nightly V-Ray build)

VRayScatter.so, VRayPatterForMaya.so are Maya plugins and should go to MAYA_PLUG_IN_PATH.
Files started with libvray_* (vray_* for Windwos) are V-Ray plugins
and should go to VRAY_FOR_MAYA<MAYA_VER>_PLUGINS_x64.

Mel files goes to MAYA_SCRIPT_PATH (AETemplate* could be stored under
the AETemplates for convenience).
Shader file should go to VRAY_FOR_MAYA2014_MAIN_x64/shaders.

If you are using default setup then:
MAYA_SCRIPT_PATH = /usr/autodesk/maya2014-x64/scripts
AETemplates = /usr/autodesk/maya2014-x64/scripts/AETemplates
MAYA_PLUG_IN_PATH = /usr/autodesk/maya2014-x64/bin/plug-ins
VRAY_FOR_MAYA2014_PLUGINS_x64 = /usr/autodesk/maya2014-x64/vray/vrayplugins
Shader txt file goes to /usr/autodesk/maya2014-x64/vray/shaders

log

Check your log for any errors, also from version 4.405.154 you can now setup environment variable ICUBE_DEBUG to 1, this will produce more info from VrayScatter

Other errors

Please make sure you download and install latest version from our forum

If this haven't solved the problem please contact us at mail@rendering.ru, by sending description of the problem together with the following information:

  • VRayScatter version
  • OS version (including 32 or 64 bit)
  • Maya version
  • V-Ray version
  • Some screenshots will be useful
  • The scene file facing the problem (if possible)
Print/export
Languages